Cannot start experiments on new Docker images


#1

Hi,

My NRP Docker containers got updated today and since then I cannot start experiments due to the following error:

Error while accessing simulation models (MaxRetryError("HTTPConnectionPool(host='localhost', port=9000): Max retries exceeded with url: /storage/storage/braitenberg_husky_holodeck_0 (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7fda38761f10>: Failed to establish a new connection: [Errno 111] Connection refused',))",)) (host: 172.19.0.3)

Am I missing a step in the update procedure?

Thanks!


#2

Hi Mahmoud, could you try to run the nrp_installer script with the reset option and then start again? Maybe the configuration of the experiments and models or the storage has to be done again.

Best,
Manos


#3

Hi Manos,

I tried that and even tried uninstalling and installing anew without luck.

During installation, this message popped up:

/bin/sed: can't read /home/bbpnrsoa/nrp/src/ExDBackend/hbp_nrp_backend/hbp_nrp_backend/config.py: No such file or directory

Is this normal?

Best,
Mahmoud


#4

Hi Mahmoud,

It is actually because an older change (config.py file having been moved) not reflected in the install script.
Please re-run it with reset or uninstall/install. It should update itself to 1.15 and then install successfully.

Best regards
Axel


#5

Thanks, this works! Are the docker images still using ROS Kinetic?


#6

No, docker images are now running ubuntu18 and ROS melodic.