Cannot stop simulation since over a week (known CLE error?)


#1

It seems one of my simulations got stuck on a online NRP server somehow:

I assume its the same issue reported in this thread. I can neither stop the simulation via the stop button or the stop all button and this instance is running since 8 days. As the “stop all” button is failing and not stopping any other simulations I have to stop my other 24 simulation manually.
So I am just wondering how long it takes until simulations are terminated automatically and whether that is still considered normal NRP behaviour.

For completeness, here the CLE Error:

ERROR TYPE: CLE Error
ERROR CODE: -1
MESSAGE: Error while communicating with the CLE (Simulation has failed). (host: 148.187.149.212)
STACK TRACE:

error@http://148.187.149.212/scripts/app.bd5c68e5.js:1:16554
controller@http://148.187.149.212/scripts/app.bd5c68e5.js:1:18466
invoke@http://148.187.149.212/node_modules/angular/angular.js:4771:19
$controllerInit@http://148.187.149.212/node_modules/angular/angular.js:10592:34
resolveSuccess@http://148.187.149.212/node_modules/angular-ui-bootstrap/dist/ui-bootstrap-tpls.js:4154:34
processQueue@http://148.187.149.212/node_modules/angular/angular.js:16696:28
qFactory/scheduleProcessQueue/<@http://148.187.149.212/node_modules/angular/angular.js:16712:39
$eval@http://148.187.149.212/node_modules/angular/angular.js:17994:28
$digest@http://148.187.149.212/node_modules/angular/angular.js:17808:31
$apply@http://148.187.149.212/node_modules/angular/angular.js:18102:24
done@http://148.187.149.212/node_modules/angular/angular.js:12082:47
completeRequest@http://148.187.149.212/node_modules/angular/angular.js:12291:15
requestLoaded@http://148.187.149.212/node_modules/angular/angular.js:12219:24 ```

Too many neurons for NRP?
#2

Hi ge69yed,
I am not sure what the default automatic termination time is, but I wouldn’t expect it to be so long.
Perhaps try some of these in the terminal:
cle-kill
or
sudo supervisorctl stop all
or
killall -9 roscore
killall -9 rosmaster

Hopefully one of those kills your simulation. Otherwise I can ask others in the HBP group and I’m sure someone would know.


#3

which terminal? how do I get there?
I am using the default online NRP servers and I do not have access to the actual backend of the servers (have I?).


#4

Dear @ge69yed
I have stopped your simulation there and backed up the logs to investigate the errors. Do we have to only stop the simulation or would you also like to know why your simulation is failing?


#5

@ge69yed, apologies, I thought you were using a local/docker CLE.
As @vahidzolf said we will look into why this is happening.


#6

As this was the only simulation stuck in such a state, and it did not happen since then again, the cause itself is not really relevant for my project. Only that the “stop all” button is working :laughing: