[CLOSED] Cloning Experiment failed, Status Code: 500


I am using the local docker installation on a windows machine. I tried to follow the second tutorial.

Launching an Experiment from the Virtual Coach — HBP Neurorobotics Platform 3.2.0 documentation

I successfully launched the virtual coach by using the front-end docker IP. However when I try to clone an experiment the (ie exp_id = vc.clone_experiment_to_storage(‘experiment’) )
following error pops up

Exception Traceback (most recent call last)
----> 1 exp_id = vc.clone_experiment_to_storage(‘experiment’)

~/nrp/src/VirtualCoach/hbp_nrp_virtual_coach/pynrp/virtual_coach.py in clone_experiment_to_storage(self, exp_id)
480 self.__config[‘proxy-services’][‘experiment-clone’], body=body)
481 if status_code != 200:
–> 482 raise Exception(‘Cloning Experiment failed, Status Code: %s’ % status_code)
483 logger.info(‘Experiment “%s” cloned successfully’, exp_id)
484 return content.decode()

Exception: Cloning Experiment failed, Status Code: 500

it would be great if you’d be able to help me with this.

Additional info:
vc.print_templates() vc.print_available_servers() vc.print_running_experiments()
Run without error the configs and experiments are displayed without problem

[CLOSED] Error 500 while cloning template in Docker Installation

For tracking : this post is related to

We’re currently trying to reproduce your error and investigating. Keep you posted.


We could run the tutorial and clone the example experiment succesfully.
So we see two possible reasons for the problem.

  1. the string passed in vc.clone_experiment_to_storage() is wrong. Did you try with the proposed ‘ExDTemplateHusky’ ?

  2. there is a problem with using ‘localhost’ in some cases as reported in https://forum.humanbrainproject.eu/t/solved-cannot-log-into-the-nrp-with-the-virtual-coach. Using the docker IP of the frontend container instead of localhost fixes it. In our case, the docker IP of the frontend container is,but it might differ in your setup. To know it, connect to the frontend container and run ifconfig

     ./nrp_installer.sh connect_frontend

Then change the constructor line to use this IP (adapt to your case)

    vc = VirtualCoach(environment='', storage_username='nrpuser', storage_password='password')

and try clone the example experiment ‘ExDTemplateHusky’ again.


I had already tried the suggested.

The virtual coach connects, and displays all possible experiments however still raises an error when cloning

This should not be an IP issue since I have already checked ifconfig in the frontend container and used it instead of the localhost

I tried with ‘ExDTemplateHusky’ and didn’t work as well.


Ok, then we need your logs from the proxy and the backend.

Connect to the frontend and attach the log files from /var/log/supervisor/proxy in your next post. Same on the backend from /var/log/supervisor/ros-simulation-factory_app/ and virtualcoach and nrp-services_app. Don’t paste them, please attach as files.


nrp-services_app.err.txt (6.1 KB)
proxy.err.txt (891 Bytes)
ros-simulation-factory_app.err.txt (344 Bytes)
ros-simulation-factory_app.out.txt (2.0 KB)
proxy.out.txt (23.3 KB)

I changed the extension to txt so that the files would be uploadable here.
The virtualcoach logs folder was empty. the nrp-services_app.out was also empty

Thank you for your support again.

PS I tried to completely uninstall the reinstall the nrp docker installation however the same issue emerged.


Any updates? I have uploaded the logs

Thank you in advance


Sorry for the delay, some in the team are on a business trip right now. I’m not sure what causes clones to fail on your end, could be that ROS is not properly started in your backend container. Can you start your docker NRP, then connect to the backend container et try to give a ROS command, like rostopic list ?


I tried running rostopic in the backend container and it ran without issues.
Thank you for taking the time :slight_smile:


Any updates on the issue?


I’m sorry, we can’t reproduce the problem. The only thing else I can see from the logs is that maybe the Models are not installed properly, since you have this empty_world_environment model not being found.

Connect to the backend and frontend and go into Models. You should have the ls output as attached.
Models-ls.txt (1.3 KB)

Models is a git managed directory, when you give

git status

it should tell you you are up to date.

git pull --rebase

should not find anything to update. If it does, that might solve it.



The git status outputs the same outputs as the file you attached.
the rebasing installed nothing new. Therefore unfortunately, the issue remains.


I forwarded to the dev team fyi. We might set up a support call if you wish and if they don’t solve your issue.