[CLOSED] Error 500 while cloning template in Docker Installation



I installed NRP using Docker containers on Windows 10 (following this guide: https://neurorobotics.net/Documentation/latest/nrp/user_manual/docker_installation.html#docker-installation)

But after starting the containers and login into NRP, I cannot create any new experiment (the tab “new experiment” is empty).

And also when trying to clone a template experiment (e.g. “Tutorial baseball experiment - Exercise”) I got an Internal Server Error 500:

Do you know why this is the case? I already run “./nrp_installer.sh restart” and “./nrp_installer.sh reset”.

Thank you for your help.


[CLOSED] Cloning Experiment failed, Status Code: 500

It could be that the backend and frontend containers don’t reach each other for some networking reason. Please connect to each container, get their IP address and try cross-ping them:

./nrp_installer.sh connect_backend
ifconfig # gives the IP address of this container
ping <other-container-IP>

Same for the frontend container.



Thanks for the quick response.
Both containers can ping each other. (on the backend container I somehow had to install iputils-ping first).

So it seems the frontend and backend can talk to each other, but issue still exists.

I just found out that I can clone the “CDP1 Mouse experiment” (but still not the Tutorial mentioned above), but after launching this error occurred:

Unfortunately, I can not upload the logs here, because I am still a new user.


That’s weird. It looks like the component called “proxy”, that is running in the frontend container is not always responding or accessible. Could it be that you have a port conflict?
Check if anything is using port 9000 or 8080 on your PC.
If you are an advanced user, you could try changing the default container ports in the installer script, then uninstall everything and reinstall.



For tracking : post related to Cloning Experiment failed, Status Code: 500


short feedback from my side:
I don’t see any port conflicts.
I also tried to install it with different ports but was not able to get it running at all.


As mentioned in the related thread, using ‘localhost’ in the VirtualCoach constructor at the start of the tutorial notebook may lead to connection issues. Try using the actual docker IP of the frontend container as explained in the other thread and try cloning again.