[CLOSED] NRP 4.0.0 Source Install not working on Ubuntu 20.04


#1

How can we fix this error?


#2

Hi Lucas,

We’re trying to reproduce your error on a fresh computer. More feedback later.
Best


#3

Thank you! We will wait.


#4

Thanks for waiting. This is a known issue and will be fixed in the next update.
Neither cython nor numpy are the requirements of the nrp-backend, so the use of pip is not needed.
Just remove import pip from setup.py


#5

Hello, I’m the Partner of Lucas, and I tried your solution. After removing import pip from all three setup.py files. After that, the build it self worked, at least it looks like it worked, because no error message. The Problem ist now, that when I try to start NRP, I get the following Problem. Hopefully someone also know why that is happening.
Best Regards
Bastian Schindler


#6

Investigating (passed on to the dev team)


#7

Thank you! We will wait again…


#8

Hi Bastian!
It might occur because of third-party libraries conflict…
Could you try in nrp-proxy/package.json

replace the line 9
"@types/lodash": "^4.14.117",
with
"@types/lodash": "4.14.186",

and replace line 46
"@types/chai": "^4.1.6",
with
"@types/chai": "4.3.3",

and repeat the installation of the NRP or call nvm use 8 && npm install --no-save in the nrp-proxy directory?

Best wishes,
Viktor


#9

I believe the backend is working in some way, but it can not connect with the localhost.
Also it is trying to connect to 8090 and not 9000.


#10

So your previous issue with npm was fixed by Viktor’s hint, right? And now you have a new issue, which is that the proxy is trying to connect to the backend on port 8090 and this fails. Correct?


#11

Hi Bastian,

Try to run nrp-reverse-proxies command. It starts the proxies needed by the NRP.

Cheers,

Ugo


#12

When I run that command, the following line is shown.


#13

Some configuration files are missing…

Have you been following this guide?

Double check the steps from:

run ./configure_nrp

As you can see those are prerequistes for nrp-reverse-proxies.


#14

Yes, I used this guide and maybe somewhere it crashed and I didn’t see it


#15

I did rerun the lines from source nrp_variables again and got the two possible problems shown in the pictures


#16


#17

Looks like nginx was not installed by configure_nrp. Try to install the system nginx first and then rerun the configure.


#18

After direct call support with you Bastian, we figured out that the nrp4 source installation has some glitches and we switched to the safer docker install. In case you experience further issues, please post in this thread.