Errors during build of fresh source install


#1

Hello,
I have been trying to install the NRP from source on ubuntu 18.04, but I keep runnnung into errors during the build. The build itself doesn’t fail, and when I start the nrp with cle-start, I can clone experiments, but not launch them because the servers are unavailable.

During the build I get these errors:
-------------------------
Nest
-------------------------

Running virtualenv with interpreter /usr/bin/python2
New python executable in /home/marie/Documents/NRP/nest-simulator/build_venv/bin/python2
Also creating executable in /home/marie/Documents/NRP/nest-simulator/build_venv/bin/python
Installing setuptools, pkg_resources, pip, wheel...done.
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
Collecting Cython==0.23.4
  Using cached Cython-0.23.4-cp27-cp27mu-manylinux1_x86_64.whl (5.6 MB)
Processing /home/marie/.cache/pip/wheels/7f/cf/1f/f54efcf8e829cc52b73733f53a7e9dd168b2554ed60d58dc89/mpi4py-2.0.0-cp27-cp27mu-linux_x86_64.whl
Installing collected packages: Cython, mpi4py
ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

hbp-nrp-cle 3.0.0 requires catkin_pkg==0.2.10, which is not installed.
hbp-nrp-cle 3.0.0 requires enum34==1.1.6, which is not installed.
hbp-nrp-cle 3.0.0 requires futures==3.0.3, which is not installed.
hbp-nrp-cle 3.0.0 requires h5py==2.6.0, which is not installed.
hbp-nrp-cle 3.0.0 requires lazyarray==0.3.2, which is not installed.
hbp-nrp-cle 3.0.0 requires lxml==3.4.0, which is not installed.
hbp-nrp-cle 3.0.0 requires matplotlib==1.5.1, which is not installed.
hbp-nrp-cle 3.0.0 requires mock==1.0.1, which is not installed.
hbp-nrp-cle 3.0.0 requires nengo==2.8.0, which is not installed.
hbp-nrp-cle 3.0.0 requires neo==0.5.2, which is not installed.
hbp-nrp-cle 3.0.0 requires netifaces==0.8, which is not installed.
hbp-nrp-cle 3.0.0 requires numpy==1.16.5, which is not installed.
hbp-nrp-cle 3.0.0 requires opencv-python, which is not installed.
hbp-nrp-cle 3.0.0 requires opencv-python==4.2.0.32, which is not installed.
hbp-nrp-cle 3.0.0 requires pexpect==3.1, which is not installed.
hbp-nrp-cle 3.0.0 requires progressbar2==3.34.0, which is not installed.
hbp-nrp-cle 3.0.0 requires psutil==2.0.0, which is not installed.
hbp-nrp-cle 3.0.0 requires PyNN==0.9.4, which is not installed.
hbp-nrp-cle 3.0.0 requires pyrsistent<=0.15.7, which is not installed.
hbp-nrp-cle 3.0.0 requires pyxb==1.2.4, which is not installed.
hbp-nrp-cle 3.0.0 requires PyYAML==3.11, which is not installed.
hbp-nrp-cle 3.0.0 requires RestrictedPython==3.6.0, which is not installed.
hbp-nrp-cle 3.0.0 requires rospkg==1.0.38, which is not installed.
hbp-nrp-cle 3.0.0 requires scipy==0.17.1, which is not installed.
hbp-nrp-cle 3.0.0 requires sPyNNaker8, which is not installed.
hbp-nrp-cle 3.0.0 requires testfixtures==3.0.2, which is not installed.
Successfully installed Cython-0.23.4 mpi4py-2.0.0

VirtualCoach

pyrsistent requires Python '&gt;=3.5' but the running Python is 2.7.17

-------------------------

ExperimentControl

-------------------------

VIRTUALENV

PYTHONPATH is set: (/home/marie/Documents/NRP/retina/build/lib:/home/marie/Documents/NRP/GazeboRosPackages/devel/lib/python2.7/dist-packages:/opt/ros/melodic/lib/python2.7/dist-packages:/home/marie/.local/lib/python2.7/site-packages:/home/marie/.local/lib/x86_64-linux-gnu/python2.7/site-packages:/home/marie/Documents/NRP/GazeboRosPackages/devel/lib/python2.7/dist-packages:/home/marie/Documents/NRP/CLE/hbp_nrp_cle:/home/marie/Documents/NRP/ExperimentControl/hbp_nrp_excontrol:/home/marie/Documents/NRP/ExperimentControl/hbp_nrp_scxml:/home/marie/Documents/NRP/ExDBackend/hbp_nrp_backend:/home/marie/Documents/NRP/ExDBackend/hbp_nrp_cleserver:/home/marie/Documents/NRP/ExDBackend/hbp_nrp_commons:/home/marie/Documents/NRP/ExDBackend/hbp_nrp_watchdog:/home/marie/Documents/NRP/ExDBackend/hbp-flask-restful-swagger-master:/home/marie/Documents/NRP/VirtualCoach/hbp_nrp_virtual_coach:/home/marie/Documents/NRP/BrainSimulation/hbp_nrp_distributed_nest) this may cause problems with the virtualenv

nrp backend proxie

Installing collected packages: funcsigs, six, mock, mock-import

ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

hbp-nrp-cle 3.0.0 requires catkin_pkg==0.2.10, which is not installed.

hbp-nrp-cle 3.0.0 requires cython==0.23.4, which is not installed.

hbp-nrp-cle 3.0.0 requires enum34==1.1.6, which is not installed.

hbp-nrp-cle 3.0.0 requires futures==3.0.3, which is not installed.

hbp-nrp-cle 3.0.0 requires h5py==2.6.0, which is not installed.

hbp-nrp-cle 3.0.0 requires lazyarray==0.3.2, which is not installed.

hbp-nrp-cle 3.0.0 requires lxml==3.4.0, which is not installed.

hbp-nrp-cle 3.0.0 requires matplotlib==1.5.1, which is not installed.

hbp-nrp-cle 3.0.0 requires mpi4py==2.0.0, which is not installed.

hbp-nrp-cle 3.0.0 requires nengo==2.8.0, which is not installed.

hbp-nrp-cle 3.0.0 requires neo==0.5.2, which is not installed.

hbp-nrp-cle 3.0.0 requires netifaces==0.8, which is not installed.

hbp-nrp-cle 3.0.0 requires numpy==1.16.5, which is not installed.

hbp-nrp-cle 3.0.0 requires opencv-python, which is not installed.

hbp-nrp-cle 3.0.0 requires opencv-python==4.2.0.32, which is not installed.

hbp-nrp-cle 3.0.0 requires pexpect==3.1, which is not installed.

hbp-nrp-cle 3.0.0 requires progressbar2==3.34.0, which is not installed.

hbp-nrp-cle 3.0.0 requires psutil==2.0.0, which is not installed.

hbp-nrp-cle 3.0.0 requires PyNN==0.9.4, which is not installed.

hbp-nrp-cle 3.0.0 requires pyrsistent&lt;=0.15.7, which is not installed.

hbp-nrp-cle 3.0.0 requires pyxb==1.2.4, which is not installed.

hbp-nrp-cle 3.0.0 requires PyYAML==3.11, which is not installed.

hbp-nrp-cle 3.0.0 requires RestrictedPython==3.6.0, which is not installed.

hbp-nrp-cle 3.0.0 requires rospkg==1.0.38, which is not installed.

hbp-nrp-cle 3.0.0 requires scipy==0.17.1, which is not installed.

hbp-nrp-cle 3.0.0 requires sPyNNaker8, which is not installed.

hbp-nrp-cle 3.0.0 requires testfixtures==3.0.2, which is not installed.

hbp-nrp-commons 3.0.0 requires catkin_pkg==0.2.10, which is not installed.

hbp-nrp-commons 3.0.0 requires pexpect==3.1, which is not installed.

hbp-nrp-commons 3.0.0 requires pyxb==1.2.4, which is not installed.

hbp-nrp-commons 3.0.0 requires PyYAML==3.11, which is not installed.

hbp-nrp-commons 3.0.0 requires rospkg==1.0.38, which is not installed.

hbp-nrp-commons 3.0.0 requires transitions==0.4.0, which is not installed.

hbp-nrp-virtual-coach 3.0.0 requires httplib2==0.12.1, which is not installed.

hbp-nrp-virtual-coach 3.0.0 requires ipykernel==4.6.0, which is not installed.

hbp-nrp-virtual-coach 3.0.0 requires ipywidgets==7.5.1, which is not installed.

hbp-nrp-virtual-coach 3.0.0 requires jupyter==1.0.0, which is not installed.

hbp-nrp-virtual-coach 3.0.0 requires pandas==0.22.0, which is not installed.

hbp-nrp-virtual-coach 3.0.0 requires progressbar2==3.34.0, which is not installed.

hbp-nrp-virtual-coach 3.0.0 requires requests, which is not installed.

hbp-nrp-virtual-coach 3.0.0 requires texttable==0.8.7, which is not installed.

hbp-nrp-cle 3.0.0 requires mock==1.0.1, but you'll have mock 3.0.5 which is incompatible.

hbp-nrp-commons 3.0.0 requires mock==1.0.1, but you'll have mock 3.0.5 which is incompatible.

hbp-nrp-virtual-coach 3.0.0 requires mock==1.0.1, but you'll have mock 3.0.5 which is incompatible.

Successfully installed funcsigs-1.0.2 mock-3.0.5 mock-import-0.0.3 six-1.15.0

&gt; nrp_backend_proxy@3.0.0 postinstall /home/marie/Documents/NRP/nrpBackendProxy

&gt; rm -rf node_modules/cxml/node_modules/@types/

Most of those packages are installes in /usr/lib/python2.7/dist-packages, albeit a more recent version of them than mentioned in the error message. For example PyNN and open-cv don’t seem to be installed at all.

I compared my PYTHONPATH to one posted in another post, and it seems to be correct. The only related thing I could find on the internet is another post in this forum (NRP build all error: from pip.locations import ImportError: cannot import name bin_user), but this seems to be a different problem, and my pip is running.

Are the modules installed in the correct folder? If not, could cpying their files in the correct folder help?

Kind regards
schwaben


[SOLVED] NRP build error in fresh install in VirtualCoach & CLE steps
#2

Dear Schwaben,

For ExperimentControl, you need to install a former version of pyrsistent by hand:

source ~/.opt/platform_venv/bin/activate
pip install pyrsistent==0.15.7
deactivate

This is a known issue and has been fixed, but is not yet available in the master branch unfortunately.

For all the other requirements not met, it looks like you use a recent version of pip. Can you check your pip version from the platform virtualenv?

source ~/.opt/platform_venv/bin activate
pip --version
deactivate

Should be 9.0.3

PyNN should be installed in your platform_venv by the CLE build. Same for opencv.

Best regards
Axel