Libneurosim support not available in NEST


#1

after updating and build (all) I get the following with cle-start

Type 'nest.help()' to find out more about NEST.
CSAConnector: libneurosim support not available in NEST.
Falling back on PyNN's default CSAConnector.
Please re-compile NEST using --with-libneurosim=PATH
/home/akshay/.opt/platform_venv/lib/python2.7/site-packages/pyNN/nest/__init__.py:54: UserWarning: Unable to install NEST extensions. Certain models may not be available.
Further details: DynamicModuleManagementError in Install: Module 'pynn_extensions' could not be opened.
The dynamic loader returned the following error: 'file not found'.

somehow nest should be compiled with libneurosim right?


#2

Please tag the question as Neurorobotics, otherwise a lot fewer people will see your question.

The NRP installation currently compiles nest without libneurosim, yes. So far, we did not experience any problems with that. However, you are of course free to compile nest yourself. All the tools required for that are already installed (as part of the NRP installation process).

The installation script for nest we use is the following:

cd $HBP/nest-simulator
virtualenv build_venv
source build_venv/bin/activate
pip install Cython==0.23.4 mpi4py==2.0.0
mkdir build && cd build
cmake -DCMAKE_INSTALL_PREFIX:PATH=$HOME/.local \
    -Dwith-gsl=ON -Dwith-mpi=ON -Dwith-music=ON \
    ..     
make -j8
make install  
# optional: install UGR's Cerebellum model plugin
cd ../SpikingCerebellum/src/CerebellumModule
mkdir build && cd build && cmake .. && make && make install
cd ../../../../build/ && cmake -DCMAKE_INSTALL_PREFIX:PATH=$HOME/.local \
    -Dwith-gsl=ON -Dwith-mpi=ON -Dwith-music=ON -Dexternal-modules=cerebellum \
    ..
make -j8
make install

# check that nest is linked with cerebellum:
dd $HOME/.local/bin/nest  
# should list libcerebellummodule.so 
# deactivate the virtual env from #4
deactivate

In this install routine, you can simply add a parameter to provide a path to libneurosim.


#3

Thanks Georg for the great feedback. I have tagged the question as Neurorobotics. And will be sure to tag appropriately for future questions.


#4

I got the same error of building nest needs Libneurosim support. I tried to build nest with the provided building scripts but I got the following errors:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
MUSIC_INCLUDE_DIRS (ADVANCED)
   used as include directory in directory /home/nrp/Documents/NRP/nest-simulator

Did you solve the problem? A detailed solution would be really appreciated!


#5

thanks all for useful info


#6

Dear Qian,
Normally, music should not be built with Nest. For some reason it is included on your side. Try to exclude it explicitely from the cmake arguments.

Best regards
Axel