Nest Cerebellum "Segmentation Fault"


Hi all,
after installing the Spiking Cerebellum Model in Nest I try to import it in the platform_venv python via

import nest

I get the error "Segmentation Fault (Core Dumped):
Current thread 0x00007f2c2d4f6740 (most recent call first):
File “/home/user/.local/lib/python2.7/site-packages/nest/”, line 110 in catching_sli_run
File “/home/user/.local/lib/python2.7/site-packages/nest/lib/”, line 153 in Install
File “/home/user/.local/lib/python2.7/site-packages/nest/lib/”, line 230 in stack_checker_func
File “”, line 2 in
Segmentation fault (core dumped)

It actually did work before, so I am not sure if it came with the ubuntu 18 update. Did anyone experience this as well, or anyone who can still successfully use it? Any hint appreciated, thanks!


Could also make sense to ask the NEST mailinglist. It could be related to the NEST installation.
What version of NEST do you have? And did you try to update it?


Thanks Jens, I now also tested on previous Nest versions down to version 2.1.2 and still get the same error.
There is already a ticket for nest that you need to add your nest install dir to LD_LIBRARY_PATH, but yes it might makes sense to follow up on the nest mailing list.
What is your procedure to install the cerebellum in NEST or do you go for spinnaker directly?


Sorry to hear it’s still a problem.
We’re using SpiNNaker through PyNN, so we’re not interacting with NEST. By the way, that could be another thing to try: interacting with NEST through PyNN. It seems like you have issues with initialising NEST. I know that NRP works with NEST through PyNN, so perhaps that is more robust? :slight_smile:
See for instance for instructions.