Proxy Error on cle-start (Fresh install)


#1

Hi,
I just completed a fresh source install and I’m having problems with npm. After executing cle-start, I get the following error:

nrp_backend_proxy@2.3.2 start /home/akl-ma/NRP/nrpBackendProxy
NODE_ENV=production node_modules/ts-node/dist/bin.js app.ts
registered capabilities (classes):

  • rosbridge_library.capabilities.call_service.CallService
  • rosbridge_library.capabilities.advertise.Advertise
  • rosbridge_library.capabilities.publish.Publish
  • rosbridge_library.capabilities.subscribe.Subscribe
  • <class ‘rosbridge_library.capabilities.defragmentation.Defragment’>
  • rosbridge_library.capabilities.advertise_service.AdvertiseService
  • rosbridge_library.capabilities.service_response.ServiceResponse
  • rosbridge_library.capabilities.unadvertise_service.UnadvertiseService
    [INFO] [1583257039.472175, 0.000000]: Rosbridge WebSocket server started on port 9090
    2020-03-03 18:37:20 GMT+0100 Error: watch /home/akl-ma/NRP/nrpBackendProxy/config.json ENOSPC
    at FSWatcher.start (fs.js:1382:19)
    at Object.fs.watch (fs.js:1408:11)
    at Object.watch (/home/akl-ma/NRP/nrpBackendProxy/utils/configurationManager.ts:84:6)
    at Object. (/home/akl-ma/NRP/nrpBackendProxy/app.ts:47:22)
    at Module._compile (module.js:653:30)
    at Module.m._compile (/home/akl-ma/NRP/nrpBackendProxy/node_modules/ts-node/src/index.ts:439:23)
    at Module._extensions…js (module.js:664:10)
    at Object.require.extensions.(anonymous function) [as .ts] (/home/akl-ma/NRP/nrpBackendProxy/node_modules/ts-node/src/index.ts:442:12)
    at Module.load (module.js:566:32)
    at tryModuleLoad (module.js:506:12)
    at Function.Module._load (module.js:498:3)
    at Function.Module.runMain (module.js:694:10)
    at Object. (/home/akl-ma/NRP/nrpBackendProxy/node_modules/ts-node/src/bin.ts:157:12)
    at Module._compile (module.js:653:30)
    at Object.Module._extensions…js (module.js:664:10)
    at Module.load (module.js:566:32)
    at tryModuleLoad (module.js:506:12)
    at Function.Module._load (module.js:498:3)
    at Function.Module.runMain (module.js:694:10)
    at startup (bootstrap_node.js:204:16)
    at bootstrap_node.js:625:3
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! nrp_backend_proxy@2.3.2 start: NODE_ENV=production node_modules/ts-node/dist/bin.js app.ts
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the nrp_backend_proxy@2.3.2 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/akl-ma/.npm/_logs/2020-03-03T17_37_20_024Z-debug.log

I tried deleting node_modules/ and package-lock.json and running npm install again, and I also tried deleting $HOME/.nvm, then reinstalling nvm and the npm packages in the proxy, all without any success.

Are there any hints on how to solve this issue?

Thanks,
Mahmoud


#2

Hi Mahmoud,

it could be related to this https://github.com/facebook/jest/issues/3254. In summary,you can try

echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p

Let me know if it worked.

Best,
Manos


#3

Hi Manos,

Yes, this fixed it, thanks a lot!

Should we maybe include this in the installation docs?

Best,
Mahmoud