[SOLVED] 500 Internal Server Error when clicking the «Launch» button in the Holodeck Husky Braitenberg experiment on SpiNNaker


It is not obvious to users why this error occurs.
It would be great to add information to the description
why this error occurs in the online version.
For example, if you clicked the “Launch” button, the experiment
would not start, but the message “There is no way to start
the online version of this project” would appear.


  1. Login to your NRP profile
  2. Open “Templates” tab
  3. Clone the “Holodeck Husky Braitenberg experiment on SpiNNaker”
  4. Select a cloned experiment (“My Experiments” tab)
  5. Press the “Launch” button

Expected result :
Should display blue progress bar
Should display progress info on blue progress bar
Should switch to black Asset Loading splash screen
Should display progress or asset loading
Should finally open gz3d view in paused state

If it is technically impossible to start the experiment,
the message "There is no way to start
the online version of this project” would appear.

Actual Result:
Experiment won’t start.

A window appears with a description of the error “rospy.ServiceExceotion”.

500 internal server error appears in the console in the network tab.


When you click on the “Close” button in the “rospy.ServiceExceotion” we find ourselves in the “My experiments” tab.


Dear user,

I guess we’re talking about the online NRP.
I tried to replicate your issue but couldn’t. If I clone and launch the Husky-SpiNNaker experiment, I get this very readable pop up error:

that says that spinnaker is unsupported on the online servers, and when I click “close”, the simulation is cleanly stopped and I get back to My Experiments.

It might be that you landed on a faulty online server though, who will normally disappear from the list of available servers. Can you re-give it a try, or give more details how the error was generated?

Best regards


It seems it is not clear from the Template description that the experiment requires SpiNNaker hardware to be installed and connected to the server. If one doesn’t know what SpiNNaker is and just gets familiar with the NRP, then the absence of SpiNNaker says nothing to the user.
For the online version the SpiNNaker experiments could be either disabled or their description could be extended, so that the user with any expertise level could understand, that these experiments will not work.


Thanks for the report, you are right, it is probably less confusing if the spinnaker experiments are removed from the production online server since they are not supported.
I created a ticket for the dev team to handle this.

Best regards and happy new year!


Ticket 283 is done and waiting for deployment.


Done and deployed in release 3.2.1.