[SOLVED] Cloned experiment vanished after editing and saving environment


Hey there,

i recently installed the NRP from source, so far so good. I can clone, launch and run simulations.
Today, i cloned the “Template Husky in empty environment”, in order to edit the environment and build my own. I worked a little on the environment, changed a few things and built some walls, obstacles etc…
However, before i quit the simulation i hit the “Save” button in the Environment-Editor. After stopping and leaving the experiment, it no longer shows up in the “My experiments” tab, and i cannot find it anywhere.

Did i do something wrong? How do i edit and save experiments/environments the right way?
I didn’t find any answer on that in the Guide Book.
I hope i can restore my work because it took me quite some time… :smiley:

Anyways, thanks for your help.



This bug was filed 2 days ago and is currently being investigated by the development team (https://hbpneurorobotics.atlassian.net/browse/NRRPLT-6853). Saving the environment messes up the experiment configuration xml file. It is not lost however, you can find your experiment in ~/.opt/nrpStorage/ and you can retrieve your environment sdf file from there and resue it in other experiments.




sorry for that, I didn’t know this problem is already being fixed.
Thanks for your answer!



hi, I get the same issue when cloning and experiment from a git repo directly in ~/opt/nrpStorage/
it wont show up in the experiment list in the nrp


Hi Camilo,

Are you getting an error in your browser console or in the cle logs?



Hi manos,
I don’t get any error, the experiment just doesn’t show up in the list.
but the experiments that are cloned from within the NRP do show up.



Could you try adding a ?dev to the end of the url and try again?