[SOLVED] Environment stucks in rendering and doesn't open


When I tried to run some of the environments, they doesn’t load and get stuck in the rendering as shown this picture and this error shows up in the console.

I am using Chrome Version 73.0.3683.86 and ubuntu 16.04 LTS

Running NRP in a no-GPU Virtual Machine


Could you try the following steps?

cd $HBP/ExDFrontend
npm run-script build

It seems like something went wrong with the Javascript build process, that should fix it.



I am experiencing the same issue. I have tried removing node_modules and running npm install. At the end I get several warning and many vulnerabilities. I have tried fixing with npm audit fix, however not all of them can be fixed. I can still successfully npm run-script build and cle-frontend. However trying to open an example tutorial template project, I experience the environment not rendering as provided by the original post author.

This is a fresh ubuntu 18.04 and NRP installation. Any recommendations?



Do you have the exact same error in the web console? (hit Ctrl+Maj+K on Firefox, Ctrl+Maj+I on Chrome, then refresh your NRP page)

Best regards


Hi Axel, I am no longer able to npm run-script build.

This is log output:

0 info it worked if it ends with ok
1 verbose cli [ ‘/home/kristijonas/.nvm/versions/node/v8.17.0/bin/node’,
1 verbose cli ‘/home/kristijonas/.nvm/versions/node/v8.17.0/bin/npm’,
1 verbose cli ‘run-script’,
1 verbose cli ‘build’ ]
2 info using npm@6.13.4
3 info using node@v8.17.0
4 verbose run-script [ ‘prebuild’, ‘build’, ‘postbuild’ ]
5 info lifecycle exdfrontend@3.0.5~prebuild: exdfrontend@3.0.5
6 info lifecycle exdfrontend@3.0.5~build: exdfrontend@3.0.5
7 verbose lifecycle exdfrontend@3.0.5~build: unsafe-perm in lifecycle true
8 verbose lifecycle exdfrontend@3.0.5~build: PATH: /home/kristijonas/.nvm/versions/node/v8.17.0/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/kristijonas/Documents/NRP/ExDFrontend/node_modules/.bin:/home/kristijonas/.nvm/versions/node/v8.17.0/bin:/home/kristijonas/.local/bin:/home/kristijonas/Documents/NRP/user-scripts:/opt/ros/melodic/bin:/home/kristijonas/.opt/bbp/nrp-services:/home/kristijonas/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
9 verbose lifecycle exdfrontend@3.0.5~build: CWD: /home/kristijonas/Documents/NRP/ExDFrontend
10 silly lifecycle exdfrontend@3.0.5~build: Args: [ ‘-c’, ‘grunt build’ ]
11 silly lifecycle exdfrontend@3.0.5~build: Returned: code: 6 signal: null
12 info lifecycle exdfrontend@3.0.5~build: Failed to exec build script
13 verbose stack Error: exdfrontend@3.0.5 build: grunt build
13 verbose stack Exit status 6
13 verbose stack at EventEmitter. (/home/kristijonas/.nvm/versions/node/v8.17.0/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
13 verbose stack at emitTwo (events.js:126:13)
13 verbose stack at EventEmitter.emit (events.js:214:7)
13 verbose stack at ChildProcess. (/home/kristijonas/.nvm/versions/node/v8.17.0/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
13 verbose stack at emitTwo (events.js:126:13)
13 verbose stack at ChildProcess.emit (events.js:214:7)
13 verbose stack at maybeClose (internal/child_process.js:915:16)
13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)
14 verbose pkgid exdfrontend@3.0.5
15 verbose cwd /home/kristijonas/Documents/NRP/ExDFrontend
16 verbose Linux 5.4.0-65-generic
17 verbose argv “/home/kristijonas/.nvm/versions/node/v8.17.0/bin/node” “/home/kristijonas/.nvm/versions/node/v8.17.0/bin/npm” “run-script” “build”
18 verbose node v8.17.0
19 verbose npm v6.13.4
20 error code ELIFECYCLE
21 error errno 6
22 error exdfrontend@3.0.5 build: grunt build
22 error Exit status 6
23 error Failed at the exdfrontend@3.0.5 build script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 6, true ]

Thanks for taking time looking at it.



Okay, just to clarify previous message.

If I choose to ignore the vulnerabilities and build without running npm audit fix, npm still builds.
Only if I try to npm audit fix, I get the log posted above.

The original issue still persist. The error from Firefox console reads:

THREE.WebGLRenderer: Error creating WebGL context. three.js:22859:12

Error: Error creating WebGL context.
undefined angular.js:14199:24



It seems you have a messed frontend. Actually, you are not supposed to do npm audit fix. Warnings and vulnerabilities are ok, we have them too.
I’d start with cleaning up a bit.
Rename your $HBP/ExDFrontend to ExDFrontend.old.
Did you update your platform first? (in user-script, run update_nrp update all)
Just let it run. If the frontend complains about warnings and vulnerabilities, ignore, try the NRP straight on and send us the web console issue again if any.



Hi Axel,

I have managed to ‘fix’ the issue by making a clean NRP reinstall, avoiding any 3rd party drivers for my dedicated GPU. I have also been trying to port an old project from earlier NRP builds and dependancies, so possibly that broke some packages. I did not pinpoint what exactly went wrong.

Thanks for you support.