[SOLVED] Fail to install from source_cle-nginx (Fresh install)


#1

Dear HBP community,
'm new to the Neurorobotics platform and was trying to install from source, following the installation guide seems fine till step 9. Build NRP.

By entering cle-nginx in my ubuntu18.04 terminal, it echos [fail]
so i tried the Troubleshoot Nginx in troubleshoot session.

Entering nginx -t -c $HOME/.local/etc/nginx/nginx.conf
it echos nginx: [alert] could not open error log file: open() “/var/log/nginx/error.log” failed (13:Permission denied)
2020/04/24 [warn] 24876#24876: the “user” directive makes sense only if the master process runs with super-user privileges, ignored in /home/user/.local/etc/nginx/nginx.conf:1
nginx: the configuration file /home/user/.local/etc/nginx/nginx.conf syntax is ok
nginx: configuration file /home/user/.local/etc/nginx/nginx.conf test is successful

so I tried $sudo nginx -t -c $HOME/.local/etc/nginx/nginx.conf
and showed only this two lines.
nginx: the configuration file /home/user/.local/etc/nginx/nginx.conf syntax is ok
nginx: configuration file /home/user/.local/etc/nginx/nginx.conf test is successful

But this doesn’t fix with the problem of cle-nginx fail,
also command $sudo cle-nginx doesn’t work.

Do you have any idea how to solve the problem?

My Ubuntu 18.04 is opened via WSL distro, is there any setting requirement I have to care about?

Thank you very much,

Best Regards,

GaryChang


#2

I changed my permission to
/var/log/nginx/error.log

now after the command
$ nginx -t -c $HOME/.local/etc/nginx/nginx.conf
it shows the following
nginx: [warn] the “user” directive makes sense only if the master process runs with super-user privileges, ignored in /home/“username”/.local/etc/nginx/nginx.conf:1
nginx: the configuration file /home/“username”/.local/etc/nginx/nginx.conf syntax is ok
nginx: configuration file /home/“username”/.local/etc/nginx/nginx.conf test is successful

I assume the warning to not be a problem, and tried command
$ cle-nginx
it still returns fail.

Could anyone help with the problem?

Thank you


#3

Dear GaryChang,

Try first to run $HBP/user-scripts/configure_nrp at first.
Then please clear up your /var/log/nginx/* files, as well as $HOME/nginx/* and then retry cle-nginx (no sudo).
Then please past the content of /var/log/nginx/* and $HOME/nginx/* here.

Best regards,
Axel


#4

Dear Axel,

Thank you very much for your reply,

I’m new to Ubuntu so it took me some time to read the error.log.
I just recently found that the error occurred due to some background software (NI web server)
occupying the port 8080, which caused the error.
The problem is solved after changing that port use,

Thank you very much,

Best Regards,

Chang