[SOLVED] NEST troubleshooting


Hello everyone,
I must update the NEST simulator on the NRP to use a custom module for my experiment.
In order to do so, I downloaded NEST 2.18.0 and proceeded with the following steps:

  • Unpacked the tarball (creating the ~/NEST/nest-simulator-2.18.0 folder)
  • Went into the nest-simulator folder insider the NRP
  • Created a new build folder (replacing the original build folder) and moved into it via Terminal
  • Run the commands
    cmake -DCMAKE_INSTALL_PREFIX:PATH=$HBP/nest-simulator ~/NEST/nest-simulator-2.18.0
    make install

Everything seemed to proceed smoothly, however when I run make installcheck I got an error:
symbol lookup error: /home/nrp/Documents/NRP/nest-simulator/bin/nest: undefined symbol _ZN4nest4Node15send_test_eventERS0_ljb

And if I now try to import NEST in Python I get:
python: /home/nrp/Documents/NRP/nest-simulator/sli/slistartup.cpp:266: SLIStartup::SLIStartup(int, char**): Assertion 'std::strlen( argv [ 0 ]) > 0' failed.

Since NEST now fails to startup and cannot be loaded, the NRP broke down too: I can reach and navigate the localhost site of the platform but cannot launch any simulation, as the time-out expires due to CLE errors.

Is there a way to upgrade the NEST version used by the platform?
Can I return to the original NEST module without reinstalling the NRP to continue working on my experiment’s transfer functions and state machine in the meanwhile?

[SOLVED] Custom NEST simulator

Dear Frances,

Sorry for the response time, where many developers were on vacation. You can always downgrade to the officially supported Nest by uninstalling (completely) your Nest 2.18, re-cloning the official NRP-Nest repo (should be in $HBP. To be sure, delete it and run $HBP/user-scripts/clone-all-repos), and rerunning the NRP build.



Hi Frances,

in NRP nest is installed by default at $HOME/.local. So after your make install you should have a duplicated NEST installation.

If you haven’t solved this yet you can:

  1. delete your $HBP/nest-simulator folder
  2. clone it back into the same location with git clone git@bitbucket.org:hbpneurorobotics/nest-simulator.git --branch=NRRPLT-6948-update-nest--to-2.18
  3. source $HBP/user-scripts/nrp_functions
  4. build_nest

This will get you an 2.18 installation. Don’t clone NEST from its github repository. NRP needs the fork in the command I posted above to work properly.