[SOLVED] Nginx problem - update NRP


I’m sorry to send you a lot of message but, after the NRP update the platform is broken. I can’t do anything. I have another problem. When I run the ./configure_nrp script and I do cle-start I have the next error:
"2017-06-22 16:48:20 GMT+0200 Failed to execute request http://localhost:8080/simulation. ERROR: Error: Status code: 502

502 Bad Gateway

502 Bad Gateway

nginx/1.4.6 (Ubuntu) "

This error has appeared me some time ago but I don’t remember how I fix if. I’ve tried a lot of thing like cle-nginx, delete the nrpbackendproxy folder and download it again and nothing works. Does anyone know how to fix it?
Thanks for all.

NRP Update nginx problems

Hey Carlos

It seems that you have nginx issue.
You could try to run the platform in offline mode with:

user-scripts/running_mode 2

You could also take a look at the nginx logs. The location of the logs is defined in nginx.conf:

cat ~/.local/etc/nginx/nginx.conf | grep error_log


I have seen this file and the error is the following:
"2017/06/22 17:38:38 [crit] 5945#0: *1 connect() to unix:///home/juancarlos/.local/etc/nginx/nrp-services.sock failed (2: No such file or directory) while connecting to upstream, client:, server: localhost, request: “GET /experiment HTTP/1.1”, upstream: “uwsgi://unix:///home/juancarlos/.local/etc/nginx/nrp-services.sock:”, host: “localhost:8080"”

The NRP is running in local mode (2)

Has anyone had this error? I can’t fix it.


same error, i’m trying to fix it but without results


Check permissions and ownership in ~/.local/etc/nginx and parent directories. It should be writable for you.