[SOLVED] No available local servers (and suddenly missing python packages)


#1

Hello,

When I run the NRP (docker install on Ubuntu 20.04), the server status is red. Restarting the NRP or the computer does not help. There are no errors shown.

I do not know what could have caused the issue, I have already been using the NRP without problems today. So I will tell a story of other weird things that happened shortly before:

I have been using the docker NRP with a virtual coach from within the backend container without problems for some time. Then, for about a week, I did not use the virtual coach that much, I was mostly modifying transfer functions from the web cockpit. I only used the backend container to modify the bibi file of my experiment. When I finally returned to the virtual coach and wanted to run a script, it turned out that many python packages cannot be imported due to some missing dependencies. pip check command within the backend container showed several dozens of missing packages, even ones that I have been using regularly before. I have installed them again (using pip) and now everything gets imported nicely. But I cannot launch the simulation due to the unavailable server.

I would be grateful for your help.


#2

Hi,

Could you attach here the frontend and backend container logs?

They are located in /var/log/supervisor/ in both containers.

Cheers


#3

Here they are:

frontend_supervisord.txt (33.1 KB)
backend_supervisord.txt (70.0 KB)


#4

I’m sorry, I mean the content of any folder in /var/log/supervisor/ (e.g. /var/log/supervisor/ros-simulation-factory_app/*

Cheers,

Ugo


#5

ros-simulation-factory_app.err.txt (52.8 KB)
ros-simulation-factory_app.out.txt (3.9 MB)


#6

frontend:
ANY subdirectory of /var/log/supervisor/ and their content
backend:
ANY subdirectory of /var/log/supervisor/ and their content


#7

Sorry, here is frontend’s proxy
proxy.out.txt (365.5 KB)
proxy.err.txt (840.2 KB)


#8

backend:
/var/log/supervisor/nrp-services_app/*


#9

I’m sorry. I understood that ros-simulation-factory_app was enough for backend. Here’s the nrp-services_app:

nrp-services_app.err.txt (1.4 MB)
The .out file is empty


#10

Something is wrong with the backend container, possibly the manual update of some package has broken some dependency.

Please reset the backend with ./nrp_installer.sh reset_backend, and try again.

The reset doesn’t affect the experiment data, keeping a backup is never a bad idea, though.

Cheers,

Ugo


#11

Thank you. That seems to have helped.
Best,
Mikołaj