[SOLVED] No backend available after update of docker NRP


I updated/reinstalled my NRP docker installation (either via ./nrp_installer.sh update or
./nrp_installer.sh install latest) and now no more back-ends are available:

I think that might be due to an error at nrp installation-time, because I do not remember that the following error occurred the last times I updated the docker (which worked fine btw.) :

Doing git config --global --add safe.directory /home/bbpnrsoa/nrp/src/Models as well as git config --global --add safe.directory /home/bbpnrsoa/nrp/src/Models and then re-installing does not solve the issue.
Also, adding respective commands to line 207 in the current nrp_installer.sh did not help either.

Support would be greatly appreciated as I currently cannot run experiments online either :cry:



We didn’t have that error reported before. The owner mismatch is unprecedented to my knowledge. What I could suggest is, if you didn’t uninstall the previous NRP version, to log in the containers and remove the Models and Experiments folder manually, after having backed up your added or modified data of course! using docker cp. Use:

./nrp_installer.sh connect_<backend|frontend>

to log into the containers.
After deletion of Models and Experiments, try updating again.
If that doesnt help, uninstall and reinstall from scratch. After uninstallation, be sure to download the latest installer script from https://neurorobotics.net/local_install.html




removing the two folders worked.
Installation went trough properly afterwards and everything runs as before.

Thank you!