[SOLVED] NRP from source Nest install ERROR Ubuntu 16.04


#1

Dear all,

I am trying to run the NRP from source installation on Ubuntu 16.04.
Whenever I reach the Nest part during ./update_nrp build all I receive
the following ERROR. How can I fix it that the correct packages are installed?

ERROR: pip’s legacy dependency resolver does not consider dependency conflicts when selecting packages. This behaviour is the source of the following dependency conflicts.
hbp-nrp-music-interface 2.3.0 requires netifaces==0.8, which is not installed.
hbp-nrp-cle 2.3.0 requires catkin_pkg==0.2.10, which is not installed.
hbp-nrp-cle 2.3.0 requires enum34==1.1.6, which is not installed.
hbp-nrp-cle 2.3.0 requires futures==3.0.3, which is not installed.
hbp-nrp-cle 2.3.0 requires h5py==2.6.0, which is not installed.
hbp-nrp-cle 2.3.0 requires lazyarray==0.2.9, which is not installed.
hbp-nrp-cle 2.3.0 requires lxml==3.4.0, which is not installed.
hbp-nrp-cle 2.3.0 requires matplotlib==1.5.1, which is not installed.
hbp-nrp-cle 2.3.0 requires mock==1.0.1, which is not installed.
hbp-nrp-cle 2.3.0 requires nengo==2.8.0, which is not installed.
hbp-nrp-cle 2.3.0 requires neo==0.5.2, which is not installed.
hbp-nrp-cle 2.3.0 requires netifaces==0.8, which is not installed.
hbp-nrp-cle 2.3.0 requires numpy==1.11.0, which is not installed.
hbp-nrp-cle 2.3.0 requires opencv-python==4.2.0.32, which is not installed.
hbp-nrp-cle 2.3.0 requires pexpect==3.1, which is not installed.
hbp-nrp-cle 2.3.0 requires progressbar2==3.34.0, which is not installed.
hbp-nrp-cle 2.3.0 requires psutil==2.0.0, which is not installed.
hbp-nrp-cle 2.3.0 requires PyNN==0.9.1, which is not installed.
hbp-nrp-cle 2.3.0 requires pyrsistent<=0.15.7, which is not installed.
hbp-nrp-cle 2.3.0 requires pyxb==1.2.4, which is not installed.
hbp-nrp-cle 2.3.0 requires PyYAML==3.11, which is not installed.
hbp-nrp-cle 2.3.0 requires RestrictedPython==3.6.0, which is not installed.
hbp-nrp-cle 2.3.0 requires rospkg==1.0.38, which is not installed.
hbp-nrp-cle 2.3.0 requires scipy==0.17.1, which is not installed.
hbp-nrp-cle 2.3.0 requires sPyNNaker8, which is not installed.
hbp-nrp-cle 2.3.0 requires testfixtures==3.0.2, which is not installed.

Thank you very much and best regards,
Thorben Schoepe


Bio-Inspired Circuits and Systems group
University of Groningen


#2

Dear Thorben,

Unfortunately, we are dropping support for Ubuntu 16 right now, because we are releasing NRP 3.1 in a few days. It will add support for Ubuntu 20 and we can’t maintain 3 Ubuntu brands.
So I would advise you to upgrade to Ubuntu 18 (Ubuntu 20 support will be beta for some time). Tips for the upgrade are available from https://bitbucket.org/hbpneurorobotics/neurorobotics-platform/src/master/ubuntu18_upgrade.md.

Best regards
Axel


#3

Dear Axel,

Thank you for the suggestion.
I upgraded to Ubuntu 18.04.
When I run “./update_nrp update all”
gazebo can not be built because of some cmake error.
It seems to me that some repositories were not updatet
correctly or something like that?
How can I solve this problem:


Gazebo

– Gazebo version 9.8.0.hbp.3.0.5
CMake Error at CMakeLists.txt:31 (message):
The parameter ENABLE_TESTS_COMPILATION is deprecated. The new behaviour is
to call ‘make tests’ explicitly to compile the testsuite. Calling ‘make’
or ‘make all’ won’t compile the tests

– Configuring incomplete, errors occurred!
See also “/home/nbsroot/Documents/NRP/gazebo/build/CMakeFiles/CMakeOutput.log”.
See also “/home/nbsroot/Documents/NRP/gazebo/build/CMakeFiles/CMakeError.log”.
gazebo


#4

Hi Thorben,

This cmake option has been removed . Perhaps you didn’t open a new shell after updating.

I’d advise to open a fresh shell, and to remove the build directories of gazebo and its requirements

rm -rf “$HBP”/{opensim,simbody,sdformat,gazebo}/build

and relaunch the build.
Best
Axel


#5

Thanks for the fast reply.
I tried your suggestion but it did not solve the problem.
I went through the point " Troubleshooting, Reinstall an existing NRP".
This solved the dependency problem.

Best regards,
Thorben


#6

Hi,

I was able to run the complete install and I can start the NRP platform now.
However, when I try to launch the husky holodek experiment I get the following error:

Error starting the simulation. (“service [/ros_cle_simulation/create_new_simulation] responded with an error: error processing request: ‘PythonTransferFunction’ object has no attribute ‘priority’”) (host: localhost)

I found an old forum entry with the same error but no solution for the local install:

How can I fix this problem?

Thank you and best regards,
Thorben


#7

Dear Thorben,

It seems the XML schemas in GazeboRosPackages have not be properly generated. Can you try re-running $HBP/user-scripts/configure_nrp and then maybe re-build GazeboRosPackage?

cd $HBP/GazeboRosPackages
rm -rf build devel
catkin_make

Best regards
Axel


#8

Dear Axel,

thanks a lot,
that solved the problem.

Best regards,
Thorben


[SOLVED] Problem with online platform