[SOLVED] Problems with NRP source installation (steps 3, 6, 8)


#21

actually in your copy of the baseball experiment, probably “my_first_experiment”


#22

Hello, I tried changing the port while resetting but jupyter notebook in the backend container still tries to open on port 8888. (When not prompted with the --port=8889 flag. With the flag, as previously, it opens on the port but the browser cannot connect.)

The --ip=0.0.0.0 flag does not help.

Best regards,
Mikołaj


#23

Sorry about that. Let’s see what the dev team can do about the ticket raised above.


#24

@mmiekus
If you want to run in a port other than 8888 you should do two things:
1- install nrp with this command :

./nrp_installer.sh -np 8889 install latest

and also specify the port when running the Jupyter server inside the container. like this:

cle-virtual-coach ipython notebook “–ip=0.0.0.0” --port=8889 tutorial_baseball.ipynb

You can also refer to our updated documentation here : https://neurorobotics.net/Documentation/versions/3.2.0-23/nrp/modules/VirtualCoach/hbp_nrp_virtual_coach/tutorials/launching_exp.html#starting-the-virtual-coach
I hope this fixes your problem


#25

Ok, thank you.
Best,
Mikołaj


#26

Fyi, the 2 tickets opened in this thread are in progress. 286 is actually done and waiting for deployment.


#27

For the record, 287 has been closed as well. The next deployment will deploy 286.


#28

Both issues fixed and deployed in 3.2.1.