[SOLVED] Trying to import the zipped model


#1

I’m trying to import the model that I made with Blender Robot designer to the platform via the importation of a zip with the browser (Google Chrome and Linux) platform.
These are the files that have been exported of the model in order to be uploaded to the platform:

However, when I try to upload the folder I get this message.

image

Am I uploading the robot the wrong way?


#2

Hi Alex,

Either the zip file has a folder which holds your files, and consequently model.config is not in the root of the zip, or the model.config is messed up. Maybe post your zip here or in some free upload tool and we’ll have a look.


#3

Hello as you can check the model.config is inside the zip file. I’ve upload it in https://drive.google.com/file/d/1IsxC4ssUGDSRHJADRzsJSoz5jNCGYZDR/view?usp=sharing if you want to try to upload it in your platform.

Thanks.


#4

Hi Alex, thanks for reposting this to the Slack channel we have created for the Bitbrain team, this will make for more fluid communications.


#5

This issue has been solved with the following suggestions:

  1. For the Robot Designer meshes and bones are not allowed to be names with a space in between, please change e.g. “meta ring” to “meta_ring” for all names that you see on the right side pane in Blender
  2. Simulation models need to include both visual and collision meshes. If only assigning collision meshes you wont see anything in Gazebo, as collision meshes are only there for the physics engine. Please reassign all meshes as visual meshes: In the “Geometries” tab select every individual mesh, “Detach selected Mesh” Select the right bone in the segment selector, and “Assign Selected Geometry to Active Segment” without selecting the option “Assign as collision mesh”
  3. Make sure the model.config does not contain any namespace tags prefixes such as ns1:.... After the export please remove all “ns1:” strings in the model.config file, for example with the find and replace function of your editor. A bug report has been created for this issue.