Stuck in the CLE engine


Hello Again,

I tried to upload my own brain. I cleared all the bugs but now I get stuck in the closed loop engine. Do you know what is going on?

Let me know as it is possible an error not indicated comes up.

Kind regards,


I guess we need some more insights on what goes wrong. Can you provide a CLE console log?
What do you mean with “cleared all the bugs”?



Hello Axel,

I have not changed the CLE code. The only thing I changed was the transfer function decorators so they point on the right nodes and the brain, which should be cleared out of bugs. My code is at this forum post if you want to have a look: ROS Bug when importing new brain.

Here is a screenshot of the situation when I try changing the brain from inside the experiment:

This is what happens when the experiment tries to run.
I hope this helps …

Kind regards,


Axel, for cleared out all the bugs. I meant the Pynn brain I constructed did not have any bugs.


Dear T.B.

I am surprised with the name of servers from the error dialogs. Where did you connect from? The NRP collab, the web site, or a previously bookmarked link? We do not update these neurorobotics-dev and neurorobotics-staging servers anymore and the online platform has moved to new resources accessible from our website at, or recently from our updated Neurorobotics collab.

Can you try your code on these newer servers (“Online Platform” button in the website). If you changed your experiment a lot, you can download the files individually from the Download buttons and upload them in the new servers. You will have to clone an experiment first, that resembles the one you are working on.



Dear Axel,

This is exactly what I (I tried this again) did as my server address when I access the platform from my firefox browser is the following:
After I access my account from the portal.
However, when I replace the previous brain by my own the experiment stays blocked in the in the initialisation of the CLE.

The screenshot is the following:

And it does not stop running.

I think this most likely storage as when I try saving my pyNN file from the GUI it says something like “Error cannot save pyNN file”.

Kind regards,



It is unclear, what the steps to generate the error are. Give me your HBP login name and I will try to find out if there is an issue in the storage, and also try out your pynn file in a new experiment.
If you can find on top of it give me the name of the experiment folder (from the online File Explorer), it would help even more.



Dear Axel,

My username is neurogeek953.
My storage filename in the collab platform is droso1, which is inside my Droso1 collab online.
Inside there is my modified bibi_configuration, my pyNN brain is inside file as well as my personalised transfer functions.

Hope this helps,


Dear Teddy,

We are able to reproduce the problem. Indeed, there is a failure when loading the brain model that prevents the simulation from running. This issue is now under investigation and you’ll be informed as soon as a fix is available.

Nevertheless, I invite you to fill an issue report here so that we can track efficiently the efforts made to address the problem.

Best regards,


Dear Luc,

I filled in the report it is under the issue #72 “CLE engine Failure when loading Brain Model”

I Hope this saves you time.

Kind regards,


Dear T.B:

Sorry for the late reply, I am investigating the issue right now. The problem is related with your brain file, I get a segmentation fault in line 335 of your brainterberg file. Meanwhile, we are working on being able to load faulty brains in the platform.

Best Regards.


Dear Cantero,

Thank you, let me know when you fixed the issue.

Kind regards,


Dear T.B.,

The issue has been fixed, the brain is loaded in a separate thread and does not block the whole NRP if it is faulty.