Updating platform from local installation's backend - server-scripts: ERROR: No such file or directory


#1

When updating the platform with the following steps -

  1. cd $HBP/user-scripts
  2. ./update_nrp update all
    an error occurs when updating all.

Something goes wrong when updating ExDBackend

-------------------------
ExDBackend

About to checkout the master branch, you have the following unstaged changes:
M hbp_nrp_backend/hbp_nrp_backend/config.py
Would you like to stash your changes [y] or you would like to abort?
[Y/n] ySaved working directory and index state WIP on master: e5c63f6 [NRRPLT-0000] Bump to 2.1.1
HEAD is now at e5c63f6 [NRRPLT-0000] Bump to 2.1.1
Already on 'master'
Your branch is up-to-date with 'origin/master'.
Current branch master is up to date.

(0.) What is happening here, is it a problem?

Error at/when_updating server-scripts

-------------------------
server-scripts

/home/bbpnrsoa/nrp/src/user-scripts/nrp_functions: line 239: cd: server-scripts: No such file or directory
ERROR

  1. Is the directory supposed to be there? (I just freshly installed the Neurorobotics platform yesterday and reset it today.) 1.1 Is this important?

Not sure how important this is, and how this problem propagates.
(I’m also having problems with running “cle-virtual-coach ipython notebook tutorial_baseball.ipynb”, errno 99)

Thank you for reading, any help is appreciated.


#2

Dear Valter,

The first issue reported (local changes in ExDBackend to be stashed) is not a problem. You had local changes in this repo, which might have been created by a former build, and you stashed them, which is correct.

The second issue is more problematic. Yes, you should have the server-scripts repo clone in your $HBP. Obviously, something went wrong when you ran the clone-all-repos script at the very beginning. Can you try running again, or manually clone server-scripts?
Without server-scripts, the NRP won’t be able to spawn gazebo.

Best regards,
Axel


#3

Dear Axel,

Looks like cloning the master branch of server-scripts [1] repository into $HBP solved that problem - no error is thrown there anymore. Now I have a similar problem with “SlurmClusterMonitor”. Cloning it [2] into $HBP didn’t solve the issue, not sure where it should be located.


SlurmClusterMonitor

/home/bbpnrsoa/nrp/src/user-scripts/nrp_functions: line 239: cd: SlurmClusterMonitor: No such file or directory
ERROR

It seems like I may have missed a step somewhere. What is the clone-all-repos script and where can I find it?

[1] - https://bitbucket.org/hbpneurorobotics/server-scripts/src/master/
[2] - https://bitbucket.org/hbpneurorobotics/slurmclustermonitor/src/master/


#4

Dear Valter,

The clone-all-repos script is in $HBP/user-scripts, you ran it in step 1.4 of the initial installation.
Now, apparently, some repos have gone for some weird reasons. You can re-run it, it should clone whatever repo is missing.

Axel


#5

Dear Axel,

I run the clone-all-repos, however I still get a probably undesirable output when running update all. Note that I use local install (not source install). Now running “cd $HBP/user-scripts;
./update_nrp update all” produces the output:

… … …
… … …
… … …
npm WARN acorn-jsx@5.0.1 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ajv-keywords@2.1.1 requires a peer of ajv@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN exdfrontend@2.1.1 license should be a valid SPDX license expression
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.7 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.7: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

added 1 package from 1 contributor and audited 15646 packages in 17.999s
found 123 vulnerabilities (16 low, 85 moderate, 21 high, 1 critical)
run npm audit fix to fix them, or npm audit for details
/home/bbpnrsoa/nrp/src/user-scripts/nrp_functions: line 380: grunt: command not found
GRUNT BUILD FAILED

I’ll get back to this problem later though, since the simulator works and there are some more urgent task I want/need to do.

Thanks,
Best,

Valters


#6

Dear Valter,

grunt is not installed by default in docker images, you can use npm install -g grunt and nrp install -g grunt-cli. You might need sudo.
Though, I’m not sure why you want to update your docker containers, since they will be overwritten when new images are available. The usual way to update a docker loacl install is to use the installer script:
./nrp_installer.sh update

Best Axel