Virtual Environment: Reach platform from host


#1

Hi!

So the platform is running in the virtual environment on my virtual lubuntu on http://localhost:9001/#/esv-private. The browser in the vm cannot display WebGL so It would be probably much easier and faster to use the hosts’ browser. Therefore I set up a port forwading. Calling http://localhost:9001/ then returns the “getting started page”. So far, so good. But when I call http://localhost:9001/#/esv-private via the host it gets stuck loading. Has anyone an idea what could be the cause?

Kind regards


#2

I’m not sure if I remember that right, but I managed to do this by changing the VM’s networking settings in VirtualBox without port-forwarding but rather by changing the first adapter’s type to bridged networking (with port-forwarding I also had the problem that the site didn’t display anything in esv-private).

Note that you then probably need to call the frontend on your host by using http://your-guest’s-local-IP:9001/#/esv-private. Also it should be necessary to change some config files so that the servers actually serve requests from anywhere else then the localhost.
That worked for me, but I still had/have some problems when running some experiments which are instantly raising some kind of exception after starting the simulation, but that’s a story for its own thread.

If there are better ways on doing this, I would be interested in them as well!


#3

Do you know the config files? When using a network bridge and the virtual os’ IP the behavior is the same.