[CLOSED] Inaccessible model


I am trying to run the myoarm_small (1 DOF Myorobotics Arm for WP4 Cerebellum Experiment) template experiment on the NRP. I get the following error when I try cloning it from a template:

I am using the docker installation of the NRP on Ubuntu 20.04. The myoarm_small model is visible in the Models folder in the docker’s files.

I will be grateful for your help with accessing the simulation.
Best regards,
Mikołaj Miękus


Hi Mikołaj,

The myoarm_small experiment has a development maturity level. That means that it is not being actively maintained/tested and thus not stable enough for public use.
I guess you know how to get access to the development template experiments (i.e. ?dev as URL parameter) since you have tried to clone it.

I’ve created a fix for the myo_arm experiment at the Experiments’ repository branch fix-myoarm-experiments. Open a terminal in the container and checkout the branch in the Experiment repository.
It should work, I tested it on my local machine.




Dear Ugo,
Thank you for your response. Yes, I wanted to access the experiment in development.

Could you please explain in greater detail how to perform the “Open a terminal in the container and checkout the branch in the Experiment repository.” part?



Dear Mikolaj,

When you installed the NRP with docker, you used this nrp_installer.sh script. This script also enables you to open a terminal in the containerS (there are 2 actually). Use this command to do so:

./nrp_installer.sh connect_backend

This opens a terminal window. You are inside the backend container, then update the Experiments:

cd Experiments
git fetch
git checkout fix-myoarm-experiments

Then leave this terminal and restart your NRP

./nrp_installer.sh restart

If later you update your NRP, don’t forget to switch your backend container back to the master branch with the same technique.



Dear Axel,
Thank you, everything seems to work now on the Linux system.
Could you please also help me with doing this on Windows 11 with virtual Ubuntu 20.04? When I try the git checkout fix-myoarm-experiments command I get an error that this pathspec did not match any file(s) known to git.



Try to list remote branches with

git branch -a

and see if fix-myoarm-experiments is there.
If not, try

git pull --rebase
git fetch
git checkout fix-myoarm-experiments


Dear Axel,
thank you, I managed to change branches by adding origin/ to the branch name. I am still getting an error while attempting to clone the experiment, though. This time it is the empty_world_environment model that seems not to exist:

This problem occurs on Windows 11 with virtual Ubuntu 20.04. On Linux it works well.



Could be that the Models docker volume is not mounted for some reason. Could you go inside the container and check if Models/ has data?


Dear Axel,
The Models/ folder has data but there is no empty_world_environment model there. There are some similarly named ones, though.



Did you compare the content with the same container in Linux?

Otherwise, it might point to a component called the “proxy” not running in the frontend container.
This could happen if you get this kind of error when starting your containers:

./nrp_installer.sh start
Checking for script updates
Restarting nrp
Starting supervisor: supervisord.
nrp container has now been restarted.
Restarting frontend
Starting supervisor:  ERROR.
frontend container has now been restarted.

In that case, I’d try to restart only the frontend container with

./nrp_installer.sh restart frontend


The Models/ folders look the same on both platforms and running the restart_frontend command does not seem to help. Doing so tells me, though, that https://neurorobotics.net/downloads/nrp_installer.sh doesn't have a valid version number. This does not show on Linux.


Ok. Interesting that you didn’t have this issue while installing and now you have it.

If you have version 1.24 of the nrp_installer.sh script (look inside), I suggest you comment out or remove the auto_update_script() function, that is from line 12 to line 46 and retry the frontend restart.


I commented the auto_update_script() function as well as line 700 which called it, and now the information about the valid version number is gone. I still get the error about the non-existing environment while trying to clone the experiment, though.


But you don’t have an error when the frontend restart, do you?

If not, you can check inside the container if everything is runnign fine:

./nrp_installer.sh connect_frontend
sudo supervisorctl status


No, I don’t get the error and everything seems to be running fine.


On your windows set up, you might have updated your docker install from a former installation? In that case, it could be that your experiments/models became incompatible, due to a recent change.
In that case, you have 2 options:

  1. go to one of the containers and update the Models and Experiments git repos manually

  2. do a full uninstall if you don’t care losing all the experiments and models

    ./nrp_installer.sh uninstall

(answer “y” when it asks if you would like to remove models and experiments, it will delete everything, please be sure)
and reinstall from scratch.


Did it fix the issue?


Unfortunately not. I just gave up on doing this on Windows and moved to Linux.


Sorry this case couldn’t be solved.