[SOLVED] Gazebo build fails on latest NRP build when using Docker



I am attempting to update the SpiNNaker Jupyter docker image to the latest NRP version. I believe that I am following the instructions for Ubuntu 20.04. This is currently failing in the build of Gazebo:

[  3%] Generating qrc_qtpropertybrowser.cpp
RCC: Error in '/home/spinnaker/Documents/NRP/gazebo/gazebo/gui/qtpropertybrowser/qtpropertybrowser.qrc': Cannot find file 'images/cursor-arrow.png'
make[2]: *** [gazebo/gui/qtpropertybrowser/CMakeFiles/gzqtpropertybrowser.dir/build.make:81: gazebo/gui/qtpropertybrowser/qrc_qtpropertybrowser.cpp] Error 1
make[1]: *** [CMakeFiles/Makefile2:4036: gazebo/gui/qtpropertybrowser/CMakeFiles/gzqtpropertybrowser.dir/all] Error 2

Did you ever come across this issue? I believe that the image file exists already…

Do you still build NRP docker images?


I believe I may have solved this now by using the NRP Docker images directly rather than trying to do the builds myself. I am still debugging this, but I can at least run cle-start sucessfully at this point…


Dear Andrew,

Indeed, we still deliver official NRP images. And they support SpiNNaker. Glad to read that you were succesful installing them.

Best regards



Glad to hear these are still being built for now; I have now got everything working again with the latest SpiNNaker version and it seems to be smooth.


Andrew :slight_smile: