[SOLVED] Localhost refused to connect



after updating the nrp_installer.sh because of some problems with saving transfer functions,
I cannot connect to the local neurorobotics platform (http://localhost:9000/#/esv-private) anymore.

I already tried to update, reset, uninstall/install, but nothing changed.
In the Terminal I found:
bin/sed: can’t read /home/bbpnrsoa/nrp/src/ExDBackend/hbp_nrp_backend/hbp_nrp_backend/config.py: No such file or directory
Maybe this could be a hint for the problem?

Maybe it is also important to know that I am using a Mac Book and the google chrome server.

Thanks for your help!


Dear Marie,

This sounds like you are using an older version of the nrp_installer.sh script itself. The latest is 1.15 and I guess you have 1.14 (read the very first lines of the nrp_installer.sh file to figure out).
Normally, the script should auto update itself to the most recent version but apparently this failed in your case.
You can redownload it from https://neurorobotics.net/local_install.html and rerun the update, it should fix your issue.

Best regards


Dear Axel,

thanks a lot for the help! I wasn’t thinking about downloading it again because I thought it will update automatically.

Nevertheless, now I got a new problem:
I uploaded my own experiment via the “import folder” function but now the sign of the Server status turned into a red color such that I am not able to launch the simulation anymore.
Do you have any idea how I could fix that?

In a small moment when the sign was still yellow at the beginning, I managed to click the button ending up with the follwing error: “Loading Experiment… Error while loading some assets! Some assets have not been found!” Which forces me to return to my main page.

Thanks in advance,


Dear Marie,

Hm, something went wrong when loading your experiment? In that case, We’d need the logs. But first try to restart your containers with:
./nrp_installer.sh restart
and retry. If it fails again, coneect to the backend container and send me the error from the logs:
./nrp_installer connect_backend
This should open a terminal inside the backend container. Then go to /var/log/supervisor/ros-simulation-factory_app and copy paste the bottom of ros-simulation-factory_app.err and ros-simulation-factory_app.out here (or wherever the error occurs).

Best regards


Dear Axel,

unfortunately restart didn’t help.

So I connected to the backend container getting the following:


sh: 0: getcwd() failed: No such file or directory (5times)
/home/bbpnrsoa/.opt/bbp/nrp-services/gzbridge: line 51: kill: (1915) - No such process
[WARN] [1575364786.687183, 0.000000]: Could not process inbound connection: [/ros_cle_simulation_285_1575363620324] is not a publisher of [/ros_cle_simulation/status]. Topics are$
sh: 0: getcwd() failed: No such file or directory


Nov 29 18:24:51 evalrcfile [Warning]: If this troubles you, type '/nestrc help' at the prompt to learn more. CSAConnector: libneurosim support not available in NEST. Falling back on PyNN's default CSAConnector. Please re-compile NEST using --with-libneurosim=PATH /home/bbpnrsoa/.opt/platform_venv/lib/python2.7/site-packages/pyNN/nest/__init__.py:54: UserWarning: Unable to install NEST extensions. Certain models may not be available. Further details: DynamicModuleManagementError in Install: Module 'pynn_extensions' could not be opened. The dynamic loader returned the following error: 'file not found'.

Thanks again for your help,


Dear Marie,

Sorry for long answer time. Maybe you fixed your problem in between.
On my side, I have the same logs in the .out file, which are no problem, just some nest extension missing and not used.
But in your .err file, there might be an issue with starting the backend component. Can you give me .err and .out from /var/log/supervisor/nrp-services_app ?

Alternatively, you could try to start the services by hand.
Connect to the backend container, and run

sudo supervisorctl stop all

Check that services are shut down with

sudo supervisorctl status

Clean up any remaining process:

sudo killall node
sudo killall python

Check there is nothing behind

ps aux

Start services:

sudo supervisorctl start all

Check they are running

sudo supervisorctl status

If still not working, kill everything like shown above and then start service manually:


In that setup, the logs will be written in the console live. To kill manually started services, use

killall nginx

Hope this helps.


When the localhost refused to connect error message appears, it is likely because the port is not correctly configured. There are many situations that might trigger “this site can’t be reached localhost refused to connect.” error in Chrome browsers . In general, the problem may happens for failing on DNS lookup . DNS is that network address that translates the website name to its internet address. Most often it causes for not getting the internet connection or misconfigured internet or network settings. Another reason could be the firewall preventing Google Chrome to load the webpage. However, other reasons, such as insufficient permissions or the Apache web server not running properly might also cause the error.