[SOLVED] ROS Terminal freezing



I have the issue that the ROS-terminal in the NRP is freezing when executing any proper ros command such as rostopic list:


This issue happens for me on both the online version 3.1 as well as on my locally installed version and on all of my browsers.

Is this a known issue and how can we get this to work again?



Dear Ludwig,

We have been able to reproduce the issue. We are going to fix it as soon as possible.

In the mean time, assuming that you are using the docker version locally, you can execute ROS commands from a terminal connected to the backend container:

./nrp_installer.sh connect_backend

Thanks for the bug report.



[SOLVED] Individually oriented wheel control - Husky

For tracking: the issue ticket is https://hbpneurorobotics.atlassian.net/browse/NUIT-266


Up the thread. :space_invader:

The NRP 3.1 terminal freezes for any command. In NRP 3.0.5, it works, but under some unknown conditions it is possible to freeze.


The fix has been deployed and is included in NRP 3.2.0.