(v2.1.2) Blank http://localhost:9000/#/esv-private after fresh local install


(After an error occurred I reset (./nrp_installer reset) the NRP as a quick fix (so far this had usually ‘fixed’ the simulator errors). This time it didn’t. Tried restarting simulation and PC, didn’t work. I even updated and later also reinstalled the NRP. The errors I typically get are to do with timeouts,…, IP addresses and ports)

After the fresh installation and starting the NRP the links http://localhost:9000/#/esv-private and both load a blank screens

Restarting NRP, restarting PC, disabling add block, switching browsers didn’t help (unlike in [1][2]).

I’ve installed NRP before and it worked.

System info:
*Ubuntu 18.04

Some related topics (these solutions didn’t seem to work for me, but I am no expert in docker or web SW engineering):
[1] - NRP Frontend and Backend on different docker containers causing problems on macOS
[2] - New NRP local install doesn’t get experiment list

Does anyone else have this problem or has had it? Any ideas on how to go about solving it? What prerequisite knowledge is needed for this? Any advice or ideas appreciated.



Dear Valter,

Indeed, the recently updated images (v2.1.2) don’t work. At least on my machine, connecting to http://localhost:9000/#/esv-private is generating lots of CORS “Access-Control-Allow-Origin” warnings, which I suspect to be the cause of the problem. Something might have changed in CORS policy that we will investigate.



Dear Valters,

Actually, the problem was not related to CORS at all, but to our proxy component in the frontend image.
We updated a fixed image and now it works nicely.
Just update your docker local install with
./nrp_installer.sh update